Train stations won't connect properly

I just got the game and I’m really enjoying it.

I tried to build a second rail line, only when I go into the train view, I add the first station, then when I add the second station, it turns red, or sometimes they both turn red, and it won’t let me add a train to the line.

Both stations are connected, with loopbacks at each end. roads connect the ‘in’ ports on one station, and the ‘out’ ports on the other, but they still won’t connect. what do I do?

Many thanks.

Yes the trains are bugged since the update. Like it will lay tracks through a train station and when you delete the track it deletes it in the station. Also it makes little sliver sections of track that seem to error the train lines as well. Its annoying as the trains worked before this last big update

So here is two of the common goofs I get. The little track thing that draws for no reason. Also how the track deletes in the station. This is after a track gets drawn through it.

1 Like

YES! those are the same issues I’ve seen too! especially the little sliver of train track that kills everything!

Yup trains are just not working. One of many setups I have tried to get the trains running. No matter I always get a red stop.

It happened to me too. Not just the rails, but also the road attached to the station got deleted as well.

I managed to delete an output-road from the train station (bottom right), after connecting a road in the wrong direction and deleting that.

Are you sure it’s not under ground? Sometimes the connection roads from mines are completely under ground when it’s on or near a slope.

There does not seem to be a slope nearby. That said, I am having trouble reproducing it and I lost the save.

Hi everyone. There might be 2 issues here with one of them already fixed:

  1. Before the last patch, if you moved a train station or replaced it, it wouldn’t connect to nearby rails. This could be the cause of the issues where the train line becomes red and unusable.

  2. Tiny broken sections of rail, missing rails in stations, like in this image:

I’m not sure if that is fixed yet. If you can reproduce it, let me know how!