Train Issues Still

FIrstly love InfraSpace, into 100’s on hours played!


Trains are the bane of this game.
I have 4 stations stopping within my map and for some reason it seems to stockpile goods at a station and never send them on a train! I have 550+ nano tubes and demand for them. But it never delivers any?

Initially I made the train as a faster way to deliver, But now they don’t get any.

Something is clearly wrong with the mechanics whereby I’m producing 3000 Steel But nothing delivers even tho there is call for it.
I’ve recently read something about the manufacturing needs to be near the ores, But if that’s not the case surely it should transport them in still? Nothing moves tho.

I’ve also just gotten into trains, and had the same issue as you. Now, idk how your loop looks like ofc, so I’m just gonna list all the thing to keep an eye on.

  • Are the train tracks in a loop
  • Are the stations listed in the “Train Lines”-tab on the left
  • Are there any miniscule gaps between the tracks and the connecting track on the stations (really reallllly small almost invisible unless you zoom all the way in)
  • If the train lines you’re trying to create, makes the stations red, its not looping properly, then check the whole line or delete the tracks, and try again.

Might be a silly question as you have more hours played than me, but do you have districts? The only time I’ve had issues like those you describe is when I had districts setup (incorrectly)

I’m not sure it’s disctricts. Goods don’t reach a train station unless they have a destination. Also, I don’t think that goods are being delivered unless the entire route is completed and functional (all tracks and roads connected). That being said, it’s always good to check if it’s districts anyway.

Did you know you can actually follow a resource’s journey all the way through the station to its final destination? Just click a truck that’s heading for a train station to see where it’s supposed to go. (Keep it selected and don’t click anywhere on the screen that would cause the tracking to stop, beacuse once it’s inside a station, you can’t select it again until it’s being picked up by a truck at the recieving station.)
This way you can follow its entire journey and maybe you can figure out what’s happening.

I am having the exact same problem. I have an industrial production facility that is connected to a train station. That station connects to my map-wide train network.

One of the things made at the facility is home appliances. My housing is divided into two areas, my starter town, and the main city. The starter town does have some home appliance production, so all of the buildings there leveled up quickly.

However, my city is starved of home appliances, and the factories in the industrial facility are all full of appliances that for some reason are not being transported to the city.

I recently had the same issue. It turns out that when I modified the track between stations I would get this issue (Home Appliances weren’t delivering to housing). I fixed it by deleting the demand (the homes) and rebuilding the buildings. This happened with other building later on the same day after the same set of circumstances (this time with Electronics’ incoming and outgoing resources) and the same fix (delete the buildings and rebuild).

I don’t have any districts setup, I really don’t understand how they operate so I simply don’t use them. I’ve tried many times and re read the instructions and just can’t figure it out.

The track is a complete and I can watch the trains from one end loop all the way around.
On the train lines tab I have them listed, for example A - B - C - D - C - B, so then it loops back to A again.

Yes when I “follow” a trucks route, it says it’s going to a building that’s requesting goods. But never arrives.

I also have ores miners sat static, even though there is a need for them. Normally this maybe a request from the other side of the map, But surely it should still send by road?

I only used the smallest stations, as the track layout really needs to be able to place 2 tracks at once, (I’m sure that’s coming (hopefully with the Super highway roads aswell)). Not all of the roads are connected. But there’s at least 1 in and 1 out.

The game uses the shortest path afaik. So if that includes trains, and assuming everything works the way it should, it will not use alternative paths, unless you disconnect a part of the road/railway. I suspect something is indeed bugged, because if it was a simple unconnected piece of railway, the game would have chosen a new shortest path. If ChuckleHead’s issues are the same as yours, his sollution should also work for you.

I would suggest securing a save game with this problem so you can send it to the devs once they request it. At the same time, try ChuckleHead’s sollution, so we can be sure it’s not a fluke, but something structural that’s broken. It wouldn’t surprise me if it is, because trains are causing a lot of issues already.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.