Test Japanese translation in game

Hi Developer.
I did test Japanese translation.
However Japanese is not displayed in game.
Because there are few translation progress?

Translator’s Dashboard
Translation Progress:

infos about missing translations for Japanese
591 translation missing in gameObjects.json
Example missing translation:“appleBasket”

Custom Translation import Errors
No errors!


Seems like there is something messed up :smiley:

I’ll check it out and get back to you!

Hey @namidasechi, I just tried it out and I was able to see some Japanese in game!

I’m not sure why it works for me and it doesn’t work for you.
Could you try downloading the current version? For me, japanese is at 14.3%. Maybe another translator fixed a problem with the syntax?

I tried various things.
Only Japanese cannot be displayed.
There is always this message.
‘The given key was not present in the dictionary.
at System.Collections.Generic.Dictionary’2 …’
IME? Font?
The dictionary?
The cause is unknown.

custom.txt is
Game Version:
Release 1.0.2
Forced language:

However,I know that I can display Japanese.

Hm, that’s strange… I put it on my list to investigate. It might take some time because of Christmas, but I’ll try to fix it quickly!

In the meantime: Do you know this website: https://www.gamespark.jp/article/2020/12/27/104951.html :slightly_smiling_face:

I just solved it.
Suddenly displayed Japanese.
I added Japanese to other translated languages and displayed it.
For example Arabic,swedish,Norwegian
Japanese was displayed without any problem.
I added Japanese to only one file and displayed it.
It was displayed properly.
No error has been issued since then.

it mean you’ve maybe done something wrong best way is to go slowly and try after EVERY changes

Great to hear that you fixed it! If anything is wrong again, let us know