Severe stuttering when any FPS cap is enabled in NVCP

I initially blamed it on something else, but after the yesterday’s update the issue persisted so I started investigating

CPU: 13700K
mobo: ASUS Z790 Creator
video card: MSI RTX4070
video driver: 546.17, also tested with the previous 2 drivers released

what I found: every time I enabled a FPS cap in the nVidia Control Panel the game would stutter, it would not stutter if I switched from FullScreen or Exclusive FullScreen to Windowed - for some reason, Windowed mode doesn’t do it

I tried with different values for the FPS cap, but the result was the same
I also tried putting the card’s power management mode to performance in the NVCP - no change

the only thing that “fixed” it was to enabling Slow VSync inside the game’s graphics options, advanced menu; with no FPS cap in NVCP
note: in NVCP, VSync is set to “Use the 3D Application Settings”

hm. it’s unlikely to have to do anything with the update. We did not change rendering code at all.

there was at least one Windows update and couple of nVidia driver releases in between

I’ll keep an eye on things and report back if anything changes

there’s something odd on how the UNITY engine handles VSync, like it always is … UNITY doesn’t have a good track record of dealing with VSync

turning off VSync in game, having a FPS cap and VSync in NVCP doesn’t show the issue
on the other hand, exiting the game resets the VSync setting to ON in the Advanced Settings submenu -so that’s a new problem


saw the latest patch notes, thanks for fixing the issue :saluting_face:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.