New mod, new question: the new mod "hides" all mods?

I’m hoping someone will have an idea what on Earth I did wrong… As far as I am aware I followed the tutorial but… When I start Founder’s Fortune, with the new mod (a simple 3D item mostly just to see if I have the hang of this, which I obviously don’t) and the two previous mods in the mod folder, I get a bunch of errors in the log and an exclamation mark on the mods button. Opening that view, it says I have no mods at all. The window is empty.

I’ve looked over the names, the spelling, counted brackets, reassembled the 3D/texture etc files three times… I’ve tried removing one at a time of the three files included (ffasset, furniture.json and localization.json) but regardless of which file(s) remains in the mod folder, all mods disappear in the game…

Any clue where I messed up?

Screenie of error log:
errorLog

When looking at logs it’s very important to look at the first error. In this case I believe there is some error in the beginning, when loading your mod, that leads to a broken mod list.

Check out the Player.log files next to your save games and see if the first error gives you an idea what might be going wrong.

Thanks for that Daniel :slight_smile:

@CharlotteA - I once encountered the Mod missing problem, though it was years ago.
From memory it was a typo or syntax issue and only a minor mistake.
So forgettable that I’ve forgotten it XD
Sorry, cannot help any more.

Thank you both :slight_smile:

I checked the player log - the “first” error, or warning, rather, actually said something about the shader (“WARNING: Shader Unsupported: ‘Hidden/Nature/Terrain/Utilities’ - All passes removed”) but further down I found that… there was no config.json file :flushed: I feel so silly - but in my defence the tutorial did not mention it! :joy:

So, the game now loads fine and all the mods are visible in the list. No errors… and no mod/new object in game. :thinking: Will have to look through it all again… and again, presumably…

A little update:
The reason the item didn’t show up in game was a missing comma. Now that it is available, I have three new issues.

  1. The item is meant to be built “against the wall”, but it ended up perpendicular to the wall… Doors for instance don’t seem to be built “at a 90 degree angle” and they show up in the right orientation, so I don’t know what causes this. (Also confusing me is that if I build something “facing me”, in Blender, it will be “facing away from me” in Unity… And now “facing the right” - compared to the section of wall - in game…)

  2. I made two icons, 512 by 512 and 128 by 128 pixels in size and named them like the tutorial said. But the small in game icon is too large and displaying “outside” the button. The big one is fine although I could definitely have used a bit more space around it…

  3. Textures didn’t load. It looks like it’s not constructed yet even when it has been constructed… The texture is in the same folder as the blender file - does it have to be in a separate texture folder before making it all into an ffasset? (A folder makes sense if you have many textures but as it was only this one…)

So… I have some more things to work on before I get this right… :thinking:

Sorry about the slow reply :blush:

The folders layout can be very specific, as that is where they will be searched for by the game.

Usually I look through other Mods of the same type and check out their layouts and use them as a guide.
Especially if I’m getting error codes :rofl:

Don’t have much time right, now but some ideas:

  1. Try rotating them in Blender and applying the rotation
  2. Yes, the icons are upscaled in the game so there is space for a shadow effect. You can just leave a transparent border around your icons to fix the size issue
  3. In Unity, you need to apply the texture to a material and the material to the model for it to work. Yes, the location of the file is important, too, but the same folder should work iirc. Look at the how the test project is set up and try to match that.

Good luck!

Again, thank you both. I haven’t had time to do much, but created the Material and Texture Folders and started reworking my item in Blender (from scratch as there were more issues than just rotation :slight_smile: )

And @Roo - obviously no need to apologize for replying late as I’m not necessarily very quick to reply either. And I’m not on a deadline or anything :wink:

My endeavours continue… The other day I made a simple vase/urn type thing just to quickly test if I could get everything right. And I did - eventually. Today I did another thingy attached to a wall. It actually ended up perfectly oriented so I have no idea why that other thing ended up at 90 degrees… BUT of course there are a few issues…

  1. This is a painting and I’ve noticed with this one as well as the GoodVibes painting in game, that they can only be attached on some walls - that is, you can’t choose which side of the wall it ends up on. Is there a way to change that? I’m guessing not, but it’s a shame. Being able to choose the side (or rotate walls so you could have one inner wall side and one outer wall side, if that makes sense) would be nice…

  2. I copied my previously working localization.json file and changed the names and descriptions. And I’m just getting “%objectname%” and “%objectnameDescription%” in the game now. I can’t see any misspellings and haven’t added or removed any brackets, commas or colons… So I don’t know why it isn’t working. Any ideas?

EDIT: And I just realised that since things end up on one side of the walls only, my idea of creating wall papers (to make the inner walls look like inner walls and not outer walls, you know…) won’t work unless each wall paper has two variants… Or I guess one might as well make double sided walls with two variants… :thinking:

Hi Charlotte

Often it is just a lot of double-checking of syntax and punctuation marks.

Just using German as a second language and a chair (chair.ffasset) as an example

localization.json

{
	"chair": {
		"english": "chair",
		"german": "Stuhl",
	},
	"chairDescription": {
		"english": "A beautiful chair for your house!",
		"german": "Ein schöner Stuhl für Ihr Haus!",
	},
}

This should be all that is required, unless I’ve missed something

Maybe Daniel will double-check and correct if need be next week.

And your config.json will be something like this:

{
	"name": "Chair Mod",
	"version": "1.0",
	"author": "roo",
	"website": "",
	"description": "Languages available : English , German

A beautiful new chair to put in your house"


	"compatibleVersions": [
		"1.1.4"
	],
}

I can’t find anything in my file that differs from that (except different names/descriptions of course and that I don’t use German :stuck_out_tongue: )

I see you use 1.1.4 for compatibleVersions, though. I’ve been using Alpha 10.0 - not that I think it affects the problem in any way, but is that something I should update? I think Alpha 10.0 is from the tutorials…

EDIT: Well… I had a comma in the text between the " " - I had looked at other examples and they use commas too… but when I removed it, it worked. :woman_shrugging:

:partying_face: Hooray :partying_face:

It feels so good when they finally work :grinning_face_with_smiling_eyes:

You could use version 1.0, but the current version is best, as you tested the Mod in v 1.1.4 so that’s why we should use that number.
The Alpha versions were testing versions and nothing is official before 1.0 (Dec2020).

The comma thing is one of those mysteries that seem to pop up occasionally - just to annoy us :joy:

It does! and… does it now? Silly comma. :smiley:


Currently all items are behaving like they should (after a long-winded Blender Mystery where the two smaller pics showed up as one pretty much all afternoon. Turns out I had added an animation. I have no idea how to do that… :flushed:) so I figure this is a good point to take a break and show a little preview.

(Not my best work, these paintings, but I mainly aimed for something quick, with a somewhat medieval AND FF feel…)

PS: And I’m guessing that guy’s name doesn’t mean Noble Trout even if it kind of looks like it, to me… :face_with_hand_over_mouth:

Very, very nice… Obviously an accomplished artist :sunglasses:
Yes, the theme suits and looks good on the wooden walls.

Forgot about the question on walls :blush:
They can be inside and outside at the same time - just depends on which way the corners go.
So I don’t think you can layer them and make them work. Do remember someone else asking a long while back.

What may be an option is to create a plain wall and use that wall as a joining wall between rooms. Be a nice feature wall for your paintings :smiley:

1 Like