Game Save Won't Load! :(

Trying to open my save, it goes through the loading process as expected. It gets to “Applying save - Game init xxxx” and then I’m taken back to the main menu. The “xxxx” is a different 4 digit number every time.

Any ideas? I was really making some good progress and would hate to lose everything :’(

Edit: I’ve closed, reopened, restarted my computer, etc. No luck.

I’m having the same issue for today. Issue seems to have started around the same time for me. I also noticed more bugs (like accidentally making infinite concrete by attempt to delete an un-deletable road) as well with the save loads before this issue.

Yes! This is for sure the same issue. So far two of my saves have been affected. Both times when working on roads.
I hope my saves are recoverable :’(

Same. Was in a game. Tried to put down a road. Game started acting weird in that I couldn’t place any more buildings. Tried to save, go to main menu, load. Now it just puts me back in the main menu when I try to load my city.

Same, the bug:

It is only happened after Alpha

if you immediately notice and delete the connected roads(if u able to do), it usually fix the bug

Edit: fix:

Hi everyone, sorry for the issue.
I just woke up and am ready to fix it.

@IrOn thanks for the video, I’m unable to reproduce it with that method though. Would you mind sending me your save so I can try it in your city?
(settings → open saves folder →

Hi, I sent it to your email


I just uploaded the fix. With Alpha 7.5.143, you should be able to load all saves and there shouldn’t be any issue when building roads. Restart Steam to trigger an immediate update.

Sorry again for the issue and let me know if anything else pops up.

1 Like

Tried on Alpha 7.5.143. On my 2 broken game saves only one work.
It was exactly the same issue.

I see. You can send the other, still broken save to me and I’ll have a look.
(settings → open saves folder →

Confirm Fixed on 7.5.144. Thanks !

1 Like

Hello, none of my recent saves open suddenly today. I have an old one from Nov 25 that loads, but it’s very out of date. It says World Creation: Voronoi Neighbors and then goes back to the main menu.

The one that loads says it’s version 7.7.151. The ones that fail to load are version 7.8.156.
Any ideas? I’ve closed and opened the game any times. Also, I can start a new game.

Last portion of Player.log
The referenced script on this Behaviour (Game Object ‘InTerra_UpdateAndCheck’) is missing!

Unloading 6 Unused Serialized files (Serialized files now loaded: 0)
UnloadTime: 5.374100 ms

Unloading 62 unused Assets to reduce memory usage. Loaded Objects now: 7310.
Total: 57.517200 ms (FindLiveObjects: 0.438200 ms CreateObjectMapping: 0.107500 ms MarkObjects: 56.773200 ms DeleteObjects: 0.197800 ms)

The referenced script on this Behaviour (Game Object ‘InTerra_UpdateAndCheck’) is missing!

Creating world with seed: 1140832327

Loading error: invalid intersection Line, at VoronoiTriangle.GetCircumCircleCenter () [0x00096] in <94a1661967ec4fc8928e3b809d785ee7>:0
at VoronoiTriangle.ContainsPointDelaunay2 (UnityEngine.Vector2 d, System.Int32 startingPoint) [0x0002f] in <94a1661967ec4fc8928e3b809d785ee7>:0
at VoronoiTriangle.IsDelaunayEdge (System.Int32 edgeIdx) [0x0005a] in <94a1661967ec4fc8928e3b809d785ee7>:0
at WorldCreator.CaclulateVoronoiTrianglesAndNeighbors () [0x00244] in <94a1661967ec4fc8928e3b809d785ee7>:0
at WorldCreator+d__21.MoveNext () [0x0018c] in <94a1661967ec4fc8928e3b809d785ee7>:0
at WorldManager+d__26.MoveNext () [0x000b6] in <94a1661967ec4fc8928e3b809d785ee7>:0
at SaveManager+d__54.MoveNext () [0x002d2] in <94a1661967ec4fc8928e3b809d785ee7>:0
at SaveManager.Update () [0x00021] in <94a1661967ec4fc8928e3b809d785ee7>:0

The referenced script on this Behaviour (Game Object ‘Main Camera’) is missing!

Unloading 6 Unused Serialized files (Serialized files now loaded: 0)
UnloadTime: 1928.780400 ms

Unloading 4048 unused Assets to reduce memory usage. Loaded Objects now: 1919.
Total: 58.827000 ms (FindLiveObjects: 0.307200 ms CreateObjectMapping: 0.146500 ms MarkObjects: 50.289400 ms DeleteObjects: 8.083200 ms)’

Hi @jeffrobins, thanks for the report and sorry for the issue!
This happened with the trains update.

I just uploaded a fix. Make sure the version in the bottom left of the main menu says Alpha 8.0.163 and if it doesn’t, restart Steam to trigger an immediate download!

Hi @Daniel, first of all I am LOVING the game. Great job =]
Im having issues loading any saved game. Current version of the game Alpha 8.0.163 and still Cant load any saves 7.8.156 or 7.7.151

Hi @BullWInKle, thanks!

I think I’m going to need your save in order to find the issue.
Settings → open saves folder →

@Daniel I sent you a save as mine won’t load either with Alpha 8.0.163

@Daniel i also have the same issue so i will send u my save to

@jeffrobins @lollypop Thanks for your saves, I just uploaded Alpha 8.0.166 with a fix!

After updating to Alpha 8.0.166 all my saved games load SUCCESFULLY !
< 3 < 3 < 3

I haven’t tested my old loads yet on 8.0.166, but a new game I started has a problem where pink cars reach a connection between 2 lane, one way streets (just a continuation of a straight line), and then disappear. Any other cars traveling down that lane now get stuck behind the invisible car. If I go to the intersection and allow the lanes to cross, then everything starts moving again.
I took a video of it. I can load my auto-saved game and watch it happen.