Game freeze after latest update

So when I launched the game this evening it did an update. I loaded a saved game that was created after release v1. I can play for 2 to 3 minutes and then it will simply freeze.

Please fix…

Thank you in advance

This is happening to me as well. Crashes within about 30 seconds after it loads the save.

yea the same i finished the update the game loads then freezes

Update: i loaded a new game and it hasnt crashed yet

1 Like

I was able to open a new game and play it through the tutorial. Same map (desert). I will try to load that now and see.

Update: The fix worked for me. Thanks for the super-quick response!

I was able to load the new save. It worked for about 20 minutes without issue. Then I quit.

Im very sorry for the issue.
It seems like this bug made it in with today’s update. We already released a fix:

Please let me know if anyone still has any issues after this update.
Thanks for the reports.


Thank you, it’s working now

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.