Friday Dev News #147 - Update 1.18.408

Hello everyone,

another week, another update!

As promised, we finally got back to doing more bug fixes. Unfortunately, we can’t release any train-related fixes today like we planned, but instead we got an other round of important fixes and changes:

Bug fixes

  • Fixed factories over delivering to habitats
  • Fixed grass growing in buildings and roads after terraforming
  • Fixed some race condition errors

UI changes

  • Luxury habitats no longer show “fulfil the additional needs to upgrade”
  • Fixed train stations and gondolas not showing resources
  • Brought back terraforming’s “progress total: x%” text
  • Improved key binding’s UI

Other changes

  • rebalanced (increased) a couple of storage limits for resources so we don’t have any delivery issues, in particular with the nuclear reactors.
  • Added a tutorial for “factory upgrades”

Also, in case you missed it: Earlier this week, we released the new UIs for all kinds of buildings. Check it out if you haven’t yet!

We’ll continue next week with more fixes. As always, let us know if there is anything in particular you need. We have a full to-do list, but it’s important to prioritise it correctly.

Happy playing!


Because the board will only let me “like” the post once:

:heart: :heart::heart::heart::heart::heart::heart::heart::heart::heart:

Thank you so every much for all the hard work the devs do!!!

Unfortunately it doesn’t seem like this is 100% fixed:

Would my save help?

edit: tried to attach save, doesn’t seem to want to do so.
edit2: watched a lvl5 building closely. Home Robots ticked down below 5.0 units, and two orders were placed. About a minute later (this residence was fairly close to the factory), the count was 4.45 units, a truck pulled in and it went up to 5.45 units. The next truck followed a few seconds later and entered the building, but the Home Robot count was not changed. This explains where a good chunk of my production is going. /sadface

This is still not fixed… but thanks for trying.

The new 54 water storage of the Simple Farm really hurts in the early game.
It takes 4,5 minutes for the simple farm to fill up the water storage from a water-air-filter building.
Cant you set the ressource storage per building, and not global?

was wondering if you could have enough storage for at least 2 production cycles, for everything?? for example, Industrial Chemicals Lab uses 4 Chems a production cycle, yet the building can only store 6. I have over a 1000 extra Chems being produced and it “can’t” keep up, because of storage.

@SilasOfBorg and @Chieri I’m sorry it’s apparently still broken!

I can’t say much because I’m not the one working on this, but I’ll forward it.
Yes, definitely send broken saves again to and we’ll check them out again.

Thanks and sorry.

Hey @SilasOfBorg and @Chieri.
Thanks for re-reporting this bug, I somehow forgot to push the fix to the update.

You’ll get the fix in the “InfraSpace 1.21” update in 30 minutes.
Apologies for forgetting.


This does appear to be fixed now – I am unable to recreate the old behavior where storage + deliveries would exceed the capacity of the habitat.

It was SO sweet to load up my city and see a wave of “Habitat Upgraded” now that I’m not wasting 50% of population-related resources. THANK YOU!!!


Are we sure about the nuclear power plant rebalance? I’m seeing it sitting at 54, which causes a “not enough power in network” popup after every cycle until it refills past 30.

Thanks a lot, it is fixed now. yay!

The devs increased the water consumption of the power plants, too… so the storage increase went to nothing… You can use water pipes to mitigate the issue to some extend, but there will still be a power shortage for a fraction of a second, because the water pipes take a few frames to get updated.

Before the rebalance, water consumption was 20 units for the nuclear power plant, and 25 for the fast neutron reactor. this changed to 30 and 50 units, making the storage increase useless for these two buildings.

In the meantime, if you’re playing on steam, this mod may help:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.