Forum image upload feedback

Trying to upload a 2mb image gives the displayed error message (Max size 4Mb). Not sure whether this is part of a larger Discourse issue, because there are a lot of similar posts from forum owners relating to image size, but based on this thread, maybe there are some options you can tweak to fix this on your side? Other posts highlight issues with the automatic resize options.

The discourse devs are not that helpful on this topic, suggesting things like “Change the image to a jpg first” which is a terrible suggestion when the forum software allows to paste PrtScn screenshots directly into the post box.

I understand this will likely be a busy time, but fine tuning the forums will help a lot in the not too distant future.

can you show me the file size of your screen ? and screenshots from F’sF also don’t open on photoshop without openning them in another software and resaving it, maybe sure it linked to your problem ^^

The screenshot above has the file size listed. Not sure what you mean by file size of my screen? The resolution is 1920x1080 if that’s what you’re after? It comes out to just over 2mb when saved as a png in, which is well below the 4mb limit, and trying to insert the png gives the same result. Had to reduce the size to around 500kb before it would work.

Trying to upload any of the recent screenshots from discussions in Discord give the same error. Try it for yourself. Upload a 2mb image in this thread.

1 Like

i believe you just wanted to know all informations, seem like a problem with discourse idk if dev can do anything, hope it’ll work soon, sorry for not helping and good luck :confused:

All good.
The Discourse issue is mainly that the error message is useless. The problem over here is how difficult it apparently can be to properly change the file size limit. The devs have likely done it to try and reduce the amount of data/bandwidth is used, which is fair enough, but whatever the limit has actually ended up being is too strict for regular users to just add a screenshot to their post, and coupled with the useless error message is just incredibly frustrating.

The other Discourse forum I’m in gives the same error message (4096kb limit) if I upload a 20+mb image, but the same screenshot I was trying to upload here uploads fine over there. This tells me something hinky is going on in the FF app.yml or something. The actual problem/solution is over my head. Figuring out that there is one is my strength! :laughing:

1 Like

Even cropping to 985KB is too large.

Alright @Xaviien thanks for looking into it and linking that Discourse post.

I changed some settings and it seems to work for me now. You can double check if it works for you too :slight_smile:


It downsized my screenshot from 1.9MB to 583KB, but idc about that. Main thing is people can just PrtScn > Paste!

You’re a legend Daniel.

1 Like

Aw, you’re a legend too! :smiley:

1 Like