Artefact's on OSX Sonoma m1

Getting troubles with artefact’s on m1.

This also applies to M2. Happens especially when having the edge of the map inside the viewport when looking at the game in any overlay mode (like placing a wind turbine). Pretty much unplayable in this state.

its also to do with the pipe network, and visualisations of anything.

I think if you zoom far enough in it stabilises. at least for Electric.

I also started a new game. and it seems to have solved the issue. annoying as I was really enjoying my first play through. I look forward to getting the bug fixed and get back to that save. in the mean time, that cheat menu looks good

New game indeed seems to “fix” it. However not sure yet if that issue will come back once enough “clutter” has amassed or whatever the issue actually is. Update: Nah, once you have any buildings in view it’s back. Zooming out real far indeed seems to fix it, however. Still meh.

playing around with it more last night. it seems to be due to the overlays of any thing. as I couldn’t even get the distribution or collects to work without going black, or flickering.

You can try the following, which solved the issue for me:

Open Terminal, enter:

nano -w ~/Library/Application\ Support/Steam/steamapps/common/InfraSpace/

Insert at the top


Press Ctrl+X, confirm with ‘Y’ to save

Run the Game. Please keep in mind that you will probably have to reapply this fix on every update. Hope it works for you.

@Developers Looks like Apple’s new GPU driver is sacrificing thread safety for performance. Maybe you can fix that, but I’d wager this is something Unity would have to fix themselves. Until then please consider testing this solution, and if it holds water include this into the MacOS build as it seems to have no measureable performance disadvantage (afaik).

Edit/Addendum: Apparently it is also required to turn off Apple’s so far rather lackluster “Game Mode”, or else the game will sporadically lock up for no apparent reason. (However just killing Game Mode doesn’t solve the GFX problems.)

Edit 2: Scrap that about game mode. It locks up less, but it still locks up occassionally.

Thanks a lot for the reports and special thanks @jeffpeng for the investigation.

Unfortunately it still seems to lock up for me, no matter if I set all the jobs to 1 or to 0.
I’m currently trying a newer Unity version, maybe that’ll be an easy solution.

Very unfortunate timing for Apple to break this one week after we released our Mac version!


Currently trying to run the AMD64 version forcing it through rosetta. Perfomance is considerably worse, of course, but I don’t have the GFX glitch even without the boot.config settings and it “seems” stable so far. Maybe “for now” running it through rosetta is the most practical solution. Gonna follow up with more later.

Update: The AMD64 version really seems to run stable… Frankly not the first Unity game I’ve come accross for which this is true. I mean it’s a shame because the native version flies in terms of loading times and such. In game… hardly matters (on a mere M2).

I just released an update, where InfraSpace was built with a newer version of Unity.
It seems fixed for me.

Let me know if any of you still encounter any issues!

Will give feedback once I had a chance to test it. Thanks for the effort helping out us unfortunate Apple people.

Update: 1.4.369 indeed seems to have fixed it. :+1:

thank you to you both!!!

@jeffpeng I didn’t use the codes, but will keep in mind. but turning off game mode made it more stable. as it would freeze on completing loading the game!!

@Daniel, I am guessing a mixture of the update and turning off game mode has resolved the flickering issue. I have just arrived back home. and am looking forward to continuing on that first save. Great game!!! Super addictive!!

I will post again if anything else crops up!!! again thank you both!!1

Credit goes to @Daniel. I just tinkered around with a few usual suspects when it comes to Unity on Mac with mediocre success.

On Game Mode: Tested 1.4.369 with and without, no lockups either way. However with Game Mode the game seems to have the occasional stutter. Game Mode is incredibly hit or miss right now, with all sorts of games. Not really sure what Apple is doing that is upsetting games, but it has to be something on the driver level since some games actually experience GFX glitches, while others have messed up pacing or broken sound, etc, so it’s more than just a renice of the process. Maybe games on Game Mode are competing with drivers for cycles? That would be insane. In any case: Game Mode needs work.

Didn’t find a way to disable Game Mode for an app on default as a publisher. However I think such an option should exist as many people aren’t savvy enough to realise their issues could be related, so for many games simply disabling it on default would be the safe bet. But I digress…

Thanks again for the unexpectedly timely fix!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.