The Pirate + Modding Update is live!

Also I’d like to notice that with diplomacy and Pirates hard mode became really hard :slight_smile: At least for me.

Thanks for the feedback @Astatroth, I’ll keep an eye on the pirate balance.

For any translation errors, you can either report them on the Discord Server or open an issue here:

Hi !
I’ve got some bugs.
When my people have a single room, it’s ok just for a little time.
Although nothing has changed and the settlers still have their room, suddenly the game tells me they do not have and they go into the red.
So I built them a house, but again the same problem: they may have a house, after an hour of play the game considers that they do not, and my settlers spend again in the Red.

Sometimes, to solve it, I just have to restart the game. But one time it didn’t work. I would have sent you a screenshot, but I erased the backup.

Another thing: I did not see any pirates after several hours of play …

oh that’s strange :o my farmer get them auto when i moove them, i don’t think i can do much for now but since it’s not too punishing to play i think it’s cool it’s more a “comfort” mode btw i’ll try to see if i can do something tho but i don’t promise anything :confused: have a nice day and play well :slight_smile:

1 Like

Hi @Ulti3484

thanks for the report. Pirates only come in the mid- to end-game, so that might be fine :slight_smile:
For the other issue, try to get a savegame where it doesn’t work and send it to me! (

What is your game version? (bottom left in the main menu)

It’s the last one, alpha 10.3
I can’t play for a least a week now, I’m sorry. I’ll try tonight but after I can’t.
I had pirates earlier, that point is ok ^^ they’re badass, 5 settlers were down.

I didn’t have the problem again with the settlers and I played for 5 hours today. But if it happens again I’ll save.

I see people saying they can move the cotton bushes. I tried, I can’t ^^

You can move cotton with Jordan’s mod. Also tthe mod allows you to move/build trees, iron ore and stone wherever you like.

@Daniel, another bug I guess - colonist often drop their injured fellows to the floor instead of bed. It’s enraging.

same problem as Ulti3484

only started playing A10 yesterday and game was in summer yr01

upgraded everyones stats to green, but after a couple of minutes one dropped back and said needed a room - also didn’t say “lives in house” which it should have (one immigrant, one house, 2 rooms)

closed the whole game down, restarted an earlier autosave, game back to normal :slight_smile:

problematic when it occurs at start of game and needing peeps in a hurry

temporary you can use dev tool to force migrant arrival as a temporary fix maybe ? :thinking:

Hi Jordan

That is a workaround which is OK for me, but game newbies will find this frustrating
as I did initially.

It no biggee :smile:

1 Like

yeah can totally agree it’s just to help people that don’t want to rage 3h on this problem untill it’s fixed

Hey, please send me the save where it goes wrong, so I can fix it!

When I have a save, it may take between 10-20 minutes to fix a bug look this, but without a save, I might be trying for hours to get the bug to appear in the first place. Thanks for the help :slight_smile:

Where to find savegames: How to find your screenshots and savegames
Send it to

Same goes for you @Astatroth.
If you can find a case where it reliably fails, or at least 75% of the time, that be a huge help!
Otherwise it’s difficult to find out why this occurs.

Got it, will send you a save game soon

The bug re-occurred during the same game just a few days later.

The problem for me is that when going back and replaying an auto-save, the problem doesn’t seem to repopulate itself… odd… but I’ve now gone past those saves.

As foto shows, house is complete, 2 rooms, 1 person living there.

I will try starting a new game and running through agains if that helps Daniel ? Don’t mind going a bit of testing :slight_smile:

have you tryed the dev tool for the “room debug” idk the name i don’t have the game bellow the eyes for now but it can tell you more if completed or not (not sure about this infos tho)

Hi Jordan

Haven’t tried debugging - just getting over the flu and trying to run alpha 10 through a normal game sequence while getting better myself.

Feeling better today, so will try out a few new restarts and see what happens :slight_smile:

1 Like

Ah, so when you reload a save, it fixes itself?
Ok, that makes it more difficult, but that’s already a valuable piece of info.
Yeah, if you can find a procedure that makes it fail (like moving the bed in and out of the house or something), that’d be great :smiley:

Just replying to tell you that it’s fixed with Alpha 10.4:

1 Like